<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":1,"applicationTime":168,"agent":""}</script>
<script type="text/javascript">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</script>
<script>
  var googleAnalyticsId = "UA-81742544-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>JayhawkSlant.com  -  Billy Preston: &quot;I'm just here to support my team.&quot;</title>
<meta content='JayhawkSlant.com  -  Billy Preston: "I&#x0027;m just here to support my team."' property='og:title'>
<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-2eada6c4ef76b32c1d573f4c7ad6fd2ed16b2c21706319015a98c50ca76b4e2e.css" />

<script src="https://cdn.rivals.com/production/assets/application-b0b83d6a3a0cc15b0251203e7d430d0d1d138232889f4a35aea2b9900ab5abc6.js"></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="AsDpFzaxDPCjrBbvbtq8FhsThNUUceDepZpOqB7LxwOtnjZ2HVbCHogQszRCbQIyRnjUx4JKzc6p5SrCThnj6A==" />
<script type="application/javascript">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</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://kansas.rivals.com/news/billy-preston-i-m-just-so-happy-for-coach-self-and-the-team-' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_thumbnail/xtgba4ogsneriqy9rsn8' property='og:image'>
<meta content='Billy Preston’s career at the University of Kansas ended before it ever had a chance to get started.&#x000A;' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-03-30 19:37:00 -0500' property='article:published_time'>
<meta content='2018-03-30 19:44:43 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "kansas.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='kansas contents-show_updated_layout' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .kansas #programming > h1 {
      background-color: #233288 !important; } }
  .kansas > header .notification-link .count-container {
    background-color: #233288 !important; }
  .kansas > header .wrapper-container {
    background-color: #233288 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .kansas > header .wrapper-container {
        border-bottom: 5px solid #bb0b31 !important; } }
  .kansas > header .invalid-email-banner {
    background-color: #233288;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .kansas > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .kansas > header .invalid-email-banner a:hover {
      color: #bb0b31; }
  @media screen and (max-width: 767px) {
    .kansas > header .mobile-header {
      background-color: #bb0b31 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .kansas > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .kansas > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .kansas > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .kansas > header .nav-row > ul,
    .kansas > header .third-nav {
      background-color: white !important; }
    .kansas > header .dropdown-toggle > i.fa {
      color: #233288 !important; } }
  .kansas > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #233288; }
  
  .site-primary-font-color {
    color: #233288; }
  
  .site-primary-background-color {
    background-color: #233288; }
  
  .site-secondary-font-color {
    color: #bb0b31; }
  
  .site-secondary-background-color {
    background-color: #bb0b31; }
  
  :root {
    --outbrain-primary-color: #233288;
    --outbrain-secondary-color: #bb0b31; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-controller='NavController as ctrl' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="//Rivals.rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Kansas" class="school-header" href="//kansas.rivals.com"><img src="https://res-1.cloudinary.com/rivals/image/upload/ezrdpbqwhm8rorlapa4f" alt="Ezrdpbqwhm8rorlapa4f" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{ ctrl.subscribePath }}'>Subscribe</a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && (ctrl.isDesktop || ctrl.isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//kansas.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;kansas&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//kansas.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;kansas&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022733105,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Billy Preston: \"I'm just here to support my team.\""
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='j' name='twitter:site'>
<meta content='Billy Preston: "I&#x0027;m just here to support my team."' name='twitter:title'>
<meta content='Billy Preston’s career at the University of Kansas ended before it ever had a chance to get started.&#x000A;' name='twitter:description'>
<meta content='https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/xtgba4ogsneriqy9rsn8' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init([{"id":1909397,"title":"Newman&#x0027;s emergence key to KU&#x0027;s Final Four run","slug":"newman-s-emergence-key-to-ku-s-final-four-run","kind":"free","site_id":59,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-30T15:25:58.849-05:00","summary":"For Malik Newman, his journey from Jackson, Miss., to San Antonio, Texas, was filled with several twists and turns.  ","deleted":false,"author_name":"Shay Wildeboor","author_title":"Editor","permalink":"https://kansas.rivals.com/news/newman-s-emergence-key-to-ku-s-final-four-run","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1909388,"title":"Slant TV: Breakout sessions with Newman, Azubuike, Graham and Mykhailiuk","slug":"slant-tv-breakout-sessions-with-newman-azubuike-graham-and-mykhailiuk","kind":"free","site_id":59,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-30T14:23:24.222-05:00","summary":"With a showdown against Villanova looming, Bill Self and his players conducted breakout interviews on Friday afternoon.","deleted":false,"author_name":"Shay Wildeboor","author_title":"Editor","permalink":"https://kansas.rivals.com/news/slant-tv-breakout-sessions-with-newman-azubuike-graham-and-mykhailiuk","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1909386,"title":"Final Four Q\u0026A: At the podium with Self, Newman, Mykhailiuk and Graham","slug":"final-four-q-a-at-the-podium-with-self-newman-mykhailiuk-and-graham","kind":"free","site_id":59,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-30T14:13:38.804-05:00","summary":"On the final day before the Final Four, Bill Self, Malik Newman, Svi Mykhailiuk and Devonte&#x0027; Graham took to the podium.","deleted":false,"author_name":"Shay Wildeboor","author_title":"Editor","permalink":"https://kansas.rivals.com/news/final-four-q-a-at-the-podium-with-self-newman-mykhailiuk-and-graham","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1909324,"title":"A closer look at the Villanova Wildcats","slug":"a-closer-look-at-the-villanova-wildcats","kind":"free","site_id":59,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-30T11:15:22.732-05:00","summary":"With a trip to the National Championship game on the line, Kansas will face Villanova in the second semifinal game.","deleted":false,"author_name":"Shay Wildeboor","author_title":"Editor","permalink":"https://kansas.rivals.com/news/a-closer-look-at-the-villanova-wildcats","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1909077,"title":"Graham enjoying Final Four experience","slug":"graham-enjoying-final-four-experience","kind":"free","site_id":59,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-29T15:25:00.000-05:00","summary":"This weekend, Kansas will look to capture its second national championship under Bill Self.\r\n\r\n","deleted":false,"author_name":"Shay Wildeboor","author_title":"Editor","permalink":"https://kansas.rivals.com/news/graham-enjoying-final-four-experience","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1909085,"title":"Final Four Q\u0026A: At the podium with Bill Self","slug":"final-four-q-a-at-the-podium-with-bill-self","kind":"free","site_id":59,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-29T15:22:42.247-05:00","summary":"Kansas head coach Bill Self spoke to the media on Thursday afternoon inside the Alamodome. ","deleted":false,"author_name":"Shay Wildeboor","author_title":"Editor","permalink":"https://kansas.rivals.com/news/final-four-q-a-at-the-podium-with-bill-self","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1909070,"title":"Slant TV: In the locker room with Graham, Newman, Azubuike and De Sousa","slug":"slant-tv-in-the-locker-room-with-graham-newman-azubuike-and-de-sousa","kind":"free","site_id":59,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-29T14:25:16.740-05:00","summary":"On Thursday afternoon, Kansas opened up its locker room to the media","deleted":false,"author_name":"Shay Wildeboor","author_title":"Editor","permalink":"https://kansas.rivals.com/news/slant-tv-in-the-locker-room-with-graham-newman-azubuike-and-de-sousa","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1908900,"title":"McDonald&#x0027;s AA Game: Prospects predict peers&#x0027; college decisions\r\n","slug":"mcdonald-s-aa-game-prospects-predict-peers-college-decisions-4","kind":"free","site_id":59,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-29T09:17:44.127-05:00","summary":"It’s our job at Rivals.com to cut through all the noise and zero in on where the nation’s top players will end up","deleted":false,"author_name":"Woody Wommack","author_title":"Rivals.com","permalink":"https://kansas.rivals.com/news/mcdonald-s-aa-game-prospects-predict-peers-college-decisions-4","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1908897,"title":"Why you always lying? McDonald&#x0027;s players brush off fibs on recruiting trail","slug":"why-you-always-lying-mcdonald-s-players-brush-off-fibs-on-recruiting-trail-1","kind":"free","site_id":59,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-29T09:15:01.322-05:00","summary":"For college coaching staffs, making recruiting pitches to elite prospects can sometimes include white lies.","deleted":false,"author_name":"Woody Wommack","author_title":"Rivals.com","permalink":"https://kansas.rivals.com/news/why-you-always-lying-mcdonald-s-players-brush-off-fibs-on-recruiting-trail-1","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1908896,"title":"Kansas recruiting class dishes on Romeo Langford and next season","slug":"kansas-recruiting-class-dishes-on-romeo-langford-and-next-season-1","kind":"free","site_id":59,"sport":"basketball","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-03-29T09:11:14.790-05:00","summary":"Eric Bossi sat down with the three KU signees at the McDonald&#x0027;s AA game for a lengthy Q\u0026A. ","deleted":false,"author_name":"Jon Kirby","author_title":"Publisher- Football Editor ","permalink":"https://kansas.rivals.com/news/kansas-recruiting-class-dishes-on-romeo-langford-and-next-season","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1908706,"title":"Spring Football: Five things to watch for","slug":"spring-football-five-things-to-watch-for","kind":"premium","site_id":59,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-28T15:38:27.933-05:00","summary":"As the Jayhawks opened up spring football practice on Wednesday afternoon. We take a look at five story lines to watch.","deleted":false,"author_name":"Jon Kirby","author_title":"Publisher- Football Editor ","permalink":"https://kansas.rivals.com/news/spring-football-five-things-to-watch-for","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1903545,"title":"Three-star DE impressed with Jayhawks following KU visit","slug":"three-star-de-impressed-with-jayhawks-following-ku-visit","kind":"premium","site_id":59,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-28T15:10:53.975-05:00","summary":"Kansas City standout Etinosa Reuben reacts to his KU visit, talks about growing up a Jayhawk fan.","deleted":false,"author_name":"Randy Withers","author_title":"Staff","permalink":"https://kansas.rivals.com/news/three-star-de-impressed-with-jayhawks-following-ku-visit","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1908404,"title":"Slant TV: On the court with Graham, Newman, Mykhailiuk, and others","slug":"slant-tv-on-the-court-with-graham-newman-mykhailiuk-and-others","kind":"free","site_id":59,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-27T18:30:40.996-05:00","summary":"To hear what Devonte&#x0027; Graham, Malik Newman, Svi Mykhailiuk and others had to say on Tuesday, come inside. ","deleted":false,"author_name":"Shay Wildeboor","author_title":"Editor","permalink":"https://kansas.rivals.com/news/slant-tv-on-the-court-with-graham-newman-mykhailiuk-and-others","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1908385,"title":"Self talks Final Four, Villanova, Devonte&#x0027; Graham and more","slug":"self-talks-final-four-villanova-devonte-graham-and-more","kind":"free","site_id":59,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-27T16:48:10.478-05:00","summary":"Before leaving for San Antonio, Bill Self and several players met with the final one final time in Lawrence.","deleted":false,"author_name":"Shay Wildeboor","author_title":"Editor","permalink":"https://kansas.rivals.com/news/self-talks-final-four-villanova-devonte-graham-and-more","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1908022,"title":"Final Four Q\u0026A: Self looking forward to returning to San Antonio","slug":"final-four-q-a-self-looking-forward-to-returning-to-san-antonio","kind":"free","site_id":59,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-26T16:00:03.162-05:00","summary":"Q. Hi, Bill. Just talk about that game against Duke yesterday; how fun was it to coach that game?BILL SELF: I told our","deleted":false,"author_name":"Shay Wildeboor","author_title":"Editor","permalink":"https://kansas.rivals.com/news/final-four-q-a-self-looking-forward-to-returning-to-san-antonio","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1907936,"title":"Kansas, Villanova commits at McDonald&#x0027;s game relish Final Four berths","slug":"kansas-villanova-commits-at-mcdonald-s-game-relish-final-four-berths-1","kind":"free","site_id":59,"sport":"football","news_type":"team","content_type":"Content::Link","live_at":"2018-03-26T12:27:08.099-05:00","summary":"KU, Villanova recruits talks about match-up between the two schools at the McDonald&#x0027;s All American game.","deleted":false,"author_name":"Jon Kirby","author_title":"Publisher- Football Editor ","permalink":"https://kansas.rivals.com/news/kansas-villanova-commits-at-mcdonald-s-game-relish-final-four-berths","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1907843,"title":"Romeo Langford goes in depth on recruiting at McDonald&#x0027;s All-American","slug":"romeo-langford-goes-in-depth-on-recruiting-at-mcdonald-s-all-american-1","kind":"free","site_id":59,"sport":"basketball","news_type":"team","content_type":"Content::Link","live_at":"2018-03-26T08:27:20.082-05:00","summary":"Eric Bossi sits down with Romeo Langford and gets the latest on his recruiting. ","deleted":false,"author_name":"Jon Kirby","author_title":"Publisher- Football Editor ","permalink":"https://kansas.rivals.com/news/romeo-langford-goes-in-depth-on-recruiting-at-mcdonald-s-all-american","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1907777,"title":"Shay&#x0027;s Slant: Closing thoughts from CenturyLink Center","slug":"shay-s-slant-closing-thoughts-from-centurylink-center","kind":"free","site_id":59,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-25T22:38:02.529-05:00","summary":"In what might have been the most entertaining game of the NCAA Tournament, Kansas edged Duke, 85-81.","deleted":false,"author_name":"Shay Wildeboor","author_title":"Editor","permalink":"https://kansas.rivals.com/news/shay-s-slant-closing-thoughts-from-centurylink-center","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1907735,"title":"Newman helps shoot Kansas past Duke and onto the Final Four","slug":"newman-helps-shoot-kansas-past-duke-and-onto-the-final-four","kind":"premium","site_id":59,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-25T21:04:00.000-05:00","summary":"For the first time since 2012, Kansas is headed back to the Final Four.\r\n\r\n","deleted":false,"author_name":"Shay Wildeboor","author_title":"Editor","permalink":"https://kansas.rivals.com/news/newman-helps-shoot-kansas-past-duke-and-onto-the-final-four","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1907745,"title":"Slant TV: Graham, Mykhailiuk, Young, Azubuike, Vick, De Sousa talk Final 4","slug":"slant-tv-graham-mykhailiuk-young-azubuike-vick-de-sousa-talk-final-4","kind":"free","site_id":59,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-25T21:03:22.036-05:00","summary":"For the latest interviews from KU&#x0027;s locker room, come inside to get the player&#x0027;s reaction from Omaha.","deleted":false,"author_name":"Shay Wildeboor","author_title":"Editor","permalink":"https://kansas.rivals.com/news/slant-tv-graham-mykhailiuk-young-azubuike-vick-de-sousa-talk-final-4","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1907711,"title":"AUDIO: Hear Self, players after the Jayhawks defeat Duke","slug":"audio-hear-self-players-after-the-jayhawks-defeat-duke","kind":"free","site_id":59,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-25T19:26:49.728-05:00","summary":"Hear what Bill Self, Graham, Newman, and Svi had to say after the win over Duke. ","deleted":false,"author_name":"Jon Kirby","author_title":"Publisher- Football Editor ","permalink":"https://kansas.rivals.com/news/audio-hear-self-players-after-the-jayhawks-defeat-duke","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]},{"id":1907707,"title":"Photos: Images from Omaha as KU advances to Final Four","slug":"photos-images-from-omaha-as-ku-advances-to-final-four","kind":"free","site_id":59,"sport":"basketball","news_type":"team","content_type":"Content::Link","live_at":"2018-03-25T19:00:53.795-05:00","summary":"See images from Omaha as KU beats Duke and advances to the Final Four ","deleted":false,"author_name":"Jon Kirby","author_title":"Publisher- Football Editor ","permalink":"https://kansas.rivals.com/galleries/1549","site_name":"JayhawkSlant.com","type":"Content","programming":[],"associated_links":[]}], nil, 59, nil, true); subdomain = &#x0027;kansas&#x0027;; aolPlayerId = &#x0027;58e686759efa8936610b8215&#x0027;; aolCompanyId = &#x0027;58e68374c7480e728bcc385f&#x0027;'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>
<div class='article-container new'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #233288'>
Ticker
</div>
<div class='news' ng-repeat='content in newsList()'>
<div class='article' ng-if='content.type === "Content"'>
<div class='forum-icon' ng-if='forumThread(content.content_type)'></div>
<a class='title' href='{{content.permalink}}' ng-class="{'indent': content.kind === 'premium'}">
<div ng-cloak>{{content.title}}</div>
</a>
<div class='byline'>
<div class='premium-icon' ng-if='content.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='link-icon' ng-if='link(content.content_type)'><?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 19.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->

<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" x="0px" y="0px" viewbox="0 0 16 12.2" enable-background="new 0 0 16 12.2" xml:space="preserve">
  <path id="XMLID_228_" fill="#0A4EA3" d="M9.1,8.8C8.3,10,7,10.7,5.5,10.7c-2.4,0-4.3-1.9-4.3-4.3s1.9-4.3,4.3-4.3
      c1.4,0,2.6,0.7,3.4,1.7h1.2C9.2,2.3,7.5,1.2,5.5,1.2c-2.9,0-5.3,2.4-5.3,5.3s2.4,5.3,5.3,5.3c2,0,3.8-1.2,4.7-2.9H9.1z"></path>
  <polygon id="XMLID_229_" fill="#0A4EA3" points="16.2,6.1 13.8,3.7 13.8,6.2 5.8,6.2 5.8,7.2 13.8,7.2 13.8,8.6 	"></polygon>
</svg>
</div>
<time datetime='{{content.live_at}}' ng-cloak>
{{timeAgo(content.live_at)}}
</time>
<a class='edit-article' href='/publishing/contents/{{content.id}}/edit' ng-show='$parent.isPublisher'>Edit</a>
</div>
</div>
<div class='tweet' ng-if='content.type === "Tweet"'>
<div class='tweet-icon'></div>
<a class='title' href='{{content.tweet_url}}' target='_blank'>
<div ng-bind-html='content.text_news_feed'></div>
</a>
</div>
</div>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>

<rv-homepage-forums ad-referer='https://kansas.rivals.com/news/billy-preston-i-m-just-so-happy-for-coach-self-and-the-team-' background-color='#233288' base-api-url='https://kansas.forums.rivals.com/' homepage='false' message-board-url='kansas.forums.rivals.com' pub-ad='null' size='size' space-id='2022733105' subscribed-user='subscribedUser'></rv-homepage-forums>


<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='new-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://kansas.rivals.com/news/billy-preston-i-m-just-so-happy-for-coach-self-and-the-team-/printable' site-name='JayhawkSlant.com'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-03-30 19:37:00 -0500') }}</span>
<span class='article-header-sport'>basketball</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1909423/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Billy Preston: &quot;I'm just here to support my team.&quot;</h2>
<div class='header-image'><figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/u3vubnhxpbx1a1glcuub)'></div>
<img src="https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/u3vubnhxpbx1a1glcuub" alt="U3vubnhxpbx1a1glcuub" />
</div>
<figcaption class='image-caption'>Billy Preston is in San Antonio to support his former teammates and the coaching staff</figcaption>
<div class='image-credit'></div>
</figure>
</div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<span>
<span class='title-sm'>
Shay Wildeboor
&bull;
</span>
<span class='type-sm'>JayhawkSlant.com</span>
<div class='type-sm'>
<a href='//twitter.com/JayhawkSlant' target='_blank'>@JayhawkSlant</a>
</div>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='title-sm'>Editor</span>
</span>
<script async charset='utf-8' src='//platform.twitter.com/widgets.js'></script>
<a class='twitter-follow-button' data-show-count='false' data-show-screen-name='false' data-size='large' href='//twitter.com/JayhawkSlant'></a>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--text article-text'>
<p><b>San Antonio -- Billy Preston</b>’s career at the University of Kansas ended before it ever had a chance to get started. </p><p>Big things were expected from <b>Billy Preston</b>, the 6-foot-9, 240-pound forward from Oak Hill Academy in Mouth of Wilson, Va. The No. 11 ranked player in the 2017 class, Preston was KU’s most heralded signee in the class and, without question, was viewed as a key component heading into the season. </p><p>However, Preston was suspended for the season opener against Tennessee State for a violation of team rules. According to Self, Preston missed curfew on Thursday night and also did not attend class on Friday.</p><p>Preston, not surprisingly, was very much looking forward to making his debut against Kentucky on November 15, but an incident that occurred in Lawrence that weekend (Saturday) prevented him from seeing his first action of the regular season.</p><p>“On Saturday, Billy was involved in a single-vehicle incident on-campus,” said Self. “There were no injuries but Billy’s car sustained damage. After I learned about the incident, I reported it to our administration. The administration determined that we needed a clearer financial picture specific to the vehicle, we decided to hold him out of tonight’s game and will continue to do that until the review is complete.</p><p>“Billy was informed right before our pre-game meal,” he added. "Needless to say, he was disappointed and crushed. He was very excited to make his KU debut. We hope to have the situation resolved as soon as possible.”</p><p>Throughout the process, Self remained hopeful that a positive ruling would be reached, but those hopes were dashed on Saturday, January 20, 2018 when news broke that Preston had signed a contact with BC Ikogea of Bosnia, the club announced.</p><p>“We are honored to have such a tremendous talent in our organization,” the team said in a release. “We were watching his situation closely and reached out to his family to show interest and ultimately reached an Agreement with the family Attorney in California on a contract for the rest of the season. We know Billy is an NBA prospect so we will do our best to continue his development to help him excel for our club and fulfill his goal which is to be an NBA star in the near future.”</p><p><br></p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ceuz9xbt0aukf3zrv7gg)'></div>
<img src="https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ceuz9xbt0aukf3zrv7gg" alt="Ceuz9xbt0aukf3zrv7gg" />
</div>
<figcaption class='image-caption'>Preston never appeared in a regular season game for Kansas</figcaption>
<div class='image-credit'></div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>Back in the United States, Preston, a former five-star prospect, made his way to the Alamodome on Friday afternoon to reunite with his former teammates and members of the coaching staff.</p><p>Shorty thereafter, <b>JayhawkSlant.com</b> reached out to Preston to talk about his reunion with the University of Kansas men’s basketball program.</p><p>“I’m doing good,” said <b>Billy Preston</b> late on Friday afternoon. “Yea, I’m just here to support my team. Yea, I’ll be at the games this weekend. If KU wins tomorrow (Saturday), I’ll be at the Championship game on Monday night. I’ll be at the game tomorrow and I’ll be here as long as Kansas is playing. I’m not sad about not being able to play this weekend, but it’s unfortunate. I’m just happy that Kansas is in the Final Four.</p><p>“I’m just so happy for Coach Self and the team,” he added. “Kansas is in a place, you know, that we had our goals set on at the beginning of the year. So, I wouldn’t say that I’m sad that it ended this way, but I’m happy for the guys and it’s unfortunate that it ended the way it did.”</p><p>Preston, during his brief tenure in Bosnia, scored a combined 21 points and pulled down 12 rebounds in 47 minutes of action. However, after appearing in just three games, Preston returned to the states after dealing with a lingering shoulder injury.</p><p>According to Preston, since returning back to the states, he’s feeling much better and is very much looking forward to the next chapter in his career.</p><p><br></p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/it0pemvbqbqyvg6f6icb)'></div>
<img src="https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/it0pemvbqbqyvg6f6icb" alt="It0pemvbqbqyvg6f6icb" />
</div>
<figcaption class='image-caption'>Preston will be in the stands this weekend</figcaption>
<div class='image-credit'>APImages.com</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>“Yea, I’m doing a lot better,” said Preston. “My first two weeks back, I was rehabbing and getting my shoulder back right. I’ve been in the gym for two or three weeks now, so I’m feeling good and in shape.</p><p>“I’m just working on my all-around game,” he added.</p>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://kansas.rivals.com/news/billy-preston-i-m-just-so-happy-for-coach-self-and-the-team-/printable' site-name='JayhawkSlant.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' ncaab-schedule-year='2017' ncaaf-schedule-year='2018' new-article-layout='true' site='{"id":59,"legacy_id":897,"name":"JayhawkSlant.com","friendly_name":"Kansas","annual_discount":null,"subdomain":"kansas","primary_color":"233288","secondary_color":"bb0b31","font_color":"ffffff","short_name":"kansas","maple_ncaaf_team_id":20,"maple_ncaaf_endpoint":"ncaaf/teams/kka","maple_ncaab_team_id":287,"maple_ncaab_endpoint":"ncaab/teams/kaa","maple_college_id":20,"google_analytics_id":"UA-81742544-1"}' twitter-feed='{"id":59,"site_id":59,"handle":"j","list_name":"","created_at":"2016-02-01T12:24:59.431-06:00","updated_at":"2018-02-07T16:57:11.267-06:00","hashtags":[],"usernames":["kuhoops","KU_Football"],"max_number":4}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://kansas.rivals.com/news/billy-preston-i-m-just-so-happy-for-coach-self-and-the-team-/printable' site-name='JayhawkSlant.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022733105', 'https://kansas.rivals.com/news/billy-preston-i-m-just-so-happy-for-coach-self-and-the-team-');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Billy Preston: \"I'm just here to support my team.\"";
  _sf_async_config.sections = 'content,content-basketball,content-basketball-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://kansas.rivals.com' data-widget-id='AR_4'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Yahoo! Inc.</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022733105",
    c7: "https://kansas.rivals.com/news/billy-preston-i-m-just-so-happy-for-coach-self-and-the-team-"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fkansas.rivals.com%2Fnews%2Fbilly-preston-i-m-just-so-happy-for-coach-self-and-the-team-&c5=2022733105&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
